Search found 9 matches

by JamesD
Fri Aug 10, 2018 4:03 am
Forum: Suggestions
Topic: Tutorial Issue
Replies: 14
Views: 211

Re: Tutorial Issue

Also, just watched the Facebook video from last night, and Joe had the same problem with the path giving an exception when it was selected, so I think it is probably a bug.
by JamesD
Fri Aug 10, 2018 1:13 am
Forum: Suggestions
Topic: Tutorial Issue
Replies: 14
Views: 211

Re: Tutorial Issue

Just figured out what caused the issue with the screens not working as I was just able to reproduce it. If I right-click in the screen and select "Reset all placements" then the game will hang when it gets to that screen. It does this even on a screen where you have placed no paths or monsters.
by JamesD
Thu Aug 09, 2018 8:20 pm
Forum: Suggestions
Topic: Tutorial Issue
Replies: 14
Views: 211

Re: Tutorial Issue

I did many times, especially after getting the exception.

I have it working now, although I still have two DirtPaths. What I did was erase the screen from the overworld and recreate it. It works now, even with the path on it.
by JamesD
Thu Aug 09, 2018 8:04 pm
Forum: Suggestions
Topic: Tutorial Issue
Replies: 14
Views: 211

Re: Tutorial Issue

I am assuming that to delete one of them, I right-click on it in the tree? But when I do that, I get the exception and no option to delete. There is no path assigned on my other two screens that work. Is that the problem?
by JamesD
Thu Aug 09, 2018 7:53 pm
Forum: Suggestions
Topic: Tutorial Issue
Replies: 14
Views: 211

Re: Tutorial Issue

PathTiles00.bmp (Converted to png so I can attach it): It is just the one from the BetaAssets folder recolored. PathTiles00.png In Pixel Editor: PixelEditor-Path.png Path Info: PathInfo.png Screen Info: ScreenInfo.png You may note that there are two "DirtPath" items listed under the Path Info node. ...
by JamesD
Thu Aug 09, 2018 7:04 pm
Forum: Suggestions
Topic: Tutorial Issue
Replies: 14
Views: 211

Re: Tutorial Issue

Thanks Dale, that is fixed, but now there is another problem. Every time I enter a screen with a path on it, I get a black screen, and the nametable is not updated in the PPU. For example, if I set the player's start screen to a screen with a path and press start, the nametable stays as the one for ...
by JamesD
Thu Aug 09, 2018 6:02 am
Forum: Suggestions
Topic: Tutorial Issue
Replies: 14
Views: 211

Re: Tutorial Issue

Okay, fixed the color and errant pixels issue. I thought I had created a two row HUD, but it was actually only one. Once I made it two rows, the colors worked correctly.

However, the player sprite still does not render.
by JamesD
Thu Aug 09, 2018 5:50 am
Forum: Suggestions
Topic: Tutorial Issue
Replies: 14
Views: 211

Tutorial Issue

I am following the NESmaker Beta1 tutorial on YouTube and have run in to some issues. (They aren't about how things are different now as I caught all of that and changed appropriately, I believe.) I have created a screen on the map in the Overworld following what was done in the tutorial. However, w...
by JamesD
Thu Aug 09, 2018 5:38 am
Forum: Help
Topic: Compile issue
Replies: 8
Views: 161

Re: Compile issue

Did you import the module? It is under Project->Import Project Module and it can be found in Modules/BasicModule.MOD