Upgrading firmware on old INL Flasher to work with NES Maker

Post Reply
User avatar
mrTentacl
Posts: 5
Joined: Sat Aug 11, 2018 6:56 pm
Location: Sweden
Contact:

Upgrading firmware on old INL Flasher to work with NES Maker

Post by mrTentacl » Sat Aug 11, 2018 7:00 pm

Hi!

I have an old flasher from INF nes lives, I tried it with NES Maker and I get this error:

[WARN] (source/usb_operations.c:142: errno: None) INL Retro-Prog found, but firmware is too old, see Readme for instructions to update firmware.

The readme points to a firmware folder that isn't included in the Nes Maker zip, that I can find at least.

Is the firmware available for download anywhere?
User avatar
dale_coop
Posts: 1456
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: Upgrading firmware on old INL Flasher to work with NES Maker

Post by dale_coop » Sat Aug 11, 2018 7:56 pm

As Joe told in a video, the NESMaker works only with the new flasher.
(the beta was working with old flasher I think)

https://youtu.be/xrNZC3J0IrM
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE
User avatar
mrTentacl
Posts: 5
Joined: Sat Aug 11, 2018 6:56 pm
Location: Sweden
Contact:

Re: Upgrading firmware on old INL Flasher to work with NES Maker

Post by mrTentacl » Wed Aug 22, 2018 12:46 pm

Turns out that you can, got this from Paul at infiniteneslives:

"You can find it on my gitlab project in the link below, in the firmware/avr_build folder.
https://gitlab.com/InfiniteNesLives/INL-retro-progdump"
User avatar
dale_coop
Posts: 1456
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: Upgrading firmware on old INL Flasher to work with NES Maker

Post by dale_coop » Wed Aug 22, 2018 1:02 pm

Oh nice, for all the nesmakers who have the old one!
Thank you, mrTentacl, for having shared.
Did you test it yourself?
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE
User avatar
Scythe&GenGames
Posts: 66
Joined: Thu Mar 08, 2018 10:20 pm
Contact:

Re: Upgrading firmware on old INL Flasher to work with NES Maker

Post by Scythe&GenGames » Fri Aug 24, 2018 8:30 am

You can also use the NEW Kazzo Flasher too Paul and Joe told me it works too!
Post Reply