Having exactly 10 input scripts causes background to disappear? *SOLVED*

Post Reply
User avatar
drexegar
Posts: 44
Joined: Wed Mar 21, 2018 12:33 pm

Having exactly 10 input scripts causes background to disappear? *SOLVED*

Post by drexegar » Tue Sep 04, 2018 9:06 am

UPDATE: When I have 10 input scripts, the background disappears in the beginning of the rom opening. It will render if I leave the screen and come back.

If I have less than 10 controls scripts or more than 10, it will render with no problem.

My level is also located at coordinates X=2 2=3 I tried somewhere else X=2 Y=0, and it rendered with no prob.
So the level I have at the coordinates for some reason doesn't like input scripts of exactly 10.

UPDATE: adding HUD elements makes the problem go away.
Attachments
scripts.PNG
scripts.PNG (235.39 KiB) Viewed 374 times
exactly 10 scripts.PNG
exactly 10 scripts.PNG (11.51 KiB) Viewed 378 times
less or more than 10.PNG
less or more than 10.PNG (24.41 KiB) Viewed 378 times
Last edited by drexegar on Thu Sep 06, 2018 12:14 am, edited 2 times in total.
User avatar
dale_coop
Posts: 1612
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: Having exactly 10 input scripts causes background to disappear?

Post by dale_coop » Tue Sep 04, 2018 10:19 am

Strange... have you set your HUD? (2rows min for the "HUD Area" and the rest for the "Playable Area")
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE
User avatar
drexegar
Posts: 44
Joined: Wed Mar 21, 2018 12:33 pm

Re: Having exactly 10 input scripts causes background to disappear?

Post by drexegar » Tue Sep 04, 2018 1:07 pm

dale_coop wrote:
Tue Sep 04, 2018 10:19 am
Strange... have you set your HUD? (2rows min for the "HUD Area" and the rest for the "Playable Area")
Yes of course its 3 rows the game works fine, it just weird when I have 10 input scripts... it might be an nes thing. Anyways just noting here no big deal, if I move to another screen the game even works with the 10 scripts.
User avatar
drexegar
Posts: 44
Joined: Wed Mar 21, 2018 12:33 pm

Re: Having exactly 10 input scripts causes background to disappear?

Post by drexegar » Thu Sep 06, 2018 12:10 am

Well problem solved when I added some HUD elements the background shows up with no problems
User avatar
dale_coop
Posts: 1612
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: Having exactly 10 input scripts causes background to disappear? *SOLVED*

Post by dale_coop » Thu Sep 06, 2018 8:26 am

Oh glad you fixed it (^_^)
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE
Post Reply