Modified Autotext Tile

darkhog
Posts: 256
Joined: Sun May 13, 2018 10:02 am

Re: Modified Autotext Tile

Post by darkhog » Wed Oct 10, 2018 6:41 pm

dale_coop wrote:
Mon Oct 08, 2018 6:04 am
Try loving the lines:

Code: Select all

    CPX player1_object  ;; check if it is the player (not a monster)
    BNE finishedWithAutoText
To the beginning of the script.
That did the trick. I mean, loving these lines didn't work (even though I love them very much! :)), but moving them did. :) :) :)
User avatar
Nintend0Nerd
Posts: 44
Joined: Tue Sep 25, 2018 4:33 pm
Location: Illinois

Re: Modified Autotext Tile

Post by Nintend0Nerd » Fri Oct 12, 2018 1:22 am

I can't get this to work. Mine doesn't even go into an infinite loop. If I stand on the tile it doesn't do anything.
Bucket Mouse
Posts: 193
Joined: Wed Mar 07, 2018 2:25 am

Re: Modified Autotext Tile

Post by Bucket Mouse » Sat Oct 13, 2018 6:31 am

We need more info.. I figure you must have missed a step but I don't know which one.
User avatar
Nintend0Nerd
Posts: 44
Joined: Tue Sep 25, 2018 4:33 pm
Location: Illinois

Re: Modified Autotext Tile

Post by Nintend0Nerd » Sat Oct 13, 2018 4:12 pm

I'll just walk through what I did. I made the autotext.asm by copying and pasting the code into a notepad. I added to to the Project Settings > Scripts Settings by pressing add. I named it Tile Collision 15, Defined it as Tile_15, and wrote the path to the asm file in the scripts box. Then I went to Project Labels > Tile Types and renamed Null - Walkable 14 to 15 - Autotext.
User avatar
Nintend0Nerd
Posts: 44
Joined: Tue Sep 25, 2018 4:33 pm
Location: Illinois

Re: Modified Autotext Tile

Post by Nintend0Nerd » Mon Oct 15, 2018 11:14 pm

I started trying to put auto text from scratch again today and now instead of just compiling and not working, it's not compiling and giving me an error. For some reason, that feels like progress :D ! I've messed around a bit and can't get the error to resolve. The error is that Line 29 has a label already defined. It printed the error three times for some reason. Does anyone know how to resolve the problem?
User avatar
dale_coop
Posts: 1593
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: Modified Autotext Tile

Post by dale_coop » Tue Oct 16, 2018 6:01 am

What is the exact error message?
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE
User avatar
Nintend0Nerd
Posts: 44
Joined: Tue Sep 25, 2018 4:33 pm
Location: Illinois

Re: Modified Autotext Tile

Post by Nintend0Nerd » Tue Oct 16, 2018 7:22 pm

Routines\UserScripts\AdventureGame_Base\TileScripts\NullTile_Walkable.asm(29): Label already defined. NullTile_Walkable is what I overwrote.
User avatar
dale_coop
Posts: 1593
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: Modified Autotext Tile

Post by dale_coop » Tue Oct 16, 2018 7:44 pm

You might have copied Passy an existing script, did you?
So you need to rename the label(s) in your script.
Because labels need to be uniques (for the whole project).
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE
User avatar
Nintend0Nerd
Posts: 44
Joined: Tue Sep 25, 2018 4:33 pm
Location: Illinois

Re: Modified Autotext Tile

Post by Nintend0Nerd » Tue Oct 16, 2018 10:29 pm

Thanks! I got it to work! One quick question, when text boxes disappear in my game, it will sometimes leave some sprites discolored. It wasn't too big of a deal, since they just change when reloading the screen, but, in a boss fight room, it might get kind of distracting. Do you know why this occurs? I think they turn into the HUD's palette.
throwawayaccount1235
Posts: 28
Joined: Wed Sep 05, 2018 3:05 pm

Re: Modified Autotext Tile

Post by throwawayaccount1235 » Tue Oct 16, 2018 10:45 pm

Can you change the text box in sprite sized increments (8 pixels)? If so, make it 1 sprite smaller or bigger so it aligns with the tiles. I think the wrong colors appear because the wrong palette gets used when the underlying tiles get redrawn.
Post Reply