Got these errors.. dont have a clue.

User avatar
axbakk
Posts: 33
Joined: Thu Sep 26, 2019 9:17 pm
Location: Axvall, Sweden

Got these errors.. dont have a clue.

Post by axbakk » Sun Oct 06, 2019 10:46 pm

Was playing around in nesmaker with an monster death animation and were trying to get a level clear object (Using scrolling platformer mod) and when i was testing the game i got these two errors.
I do not know why..
Any tips..
Attachments
654E01A9-6CC5-4C35-B47D-BD3A178A4AB8.jpeg
654E01A9-6CC5-4C35-B47D-BD3A178A4AB8.jpeg (236.2 KiB) Viewed 101 times
BBD3A793-65FC-4E36-82F3-65A0154E3A99.jpeg
BBD3A793-65FC-4E36-82F3-65A0154E3A99.jpeg (167.28 KiB) Viewed 101 times
86E14C95-A511-4F52-AD16-C4966C757CF9.jpeg
86E14C95-A511-4F52-AD16-C4966C757CF9.jpeg (232.88 KiB) Viewed 101 times
6A25C7AC-FE97-4F34-AFDA-E3E63B899A16.jpeg
6A25C7AC-FE97-4F34-AFDA-E3E63B899A16.jpeg (200.88 KiB) Viewed 101 times
7214FDFE-3550-4B66-A3D1-97B97D4834BF.jpeg
7214FDFE-3550-4B66-A3D1-97B97D4834BF.jpeg (526.5 KiB) Viewed 101 times
Noobing around NESmaker just for fun! Totally noob in gamemaking and have no experience in programming! But I love retrogames! :D
User avatar
axbakk
Posts: 33
Joined: Thu Sep 26, 2019 9:17 pm
Location: Axvall, Sweden

Re: Got these errors.. dont have a clue.

Post by axbakk » Mon Oct 07, 2019 6:29 am

Anyone?! 😊
Where do I start looking for problems...
Noobing around NESmaker just for fun! Totally noob in gamemaking and have no experience in programming! But I love retrogames! :D
User avatar
Mugi
Posts: 713
Joined: Thu Dec 27, 2018 8:30 pm

Re: Got these errors.. dont have a clue.

Post by Mugi » Mon Oct 07, 2019 7:33 am

i'd start from where the error happens; line 26 of the createobject macro
"what are you up to?" "Oh, not much... just... Parallaxing"
- Raftronaut
User avatar
dale_coop
Posts: 4206
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: Got these errors.. dont have a clue.

Post by dale_coop » Mon Oct 07, 2019 8:13 am

Seeing those screenshots... you "disabled" the OBJ_MONSTER_DEATH user constant. I think it's your issue here.
Open the "Project Settings > User Constant", select that constant and click on the "Enable" button.
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE / UNDERGROUND ADVENTURE (Arcade version - Byte-Off-2019)
User avatar
axbakk
Posts: 33
Joined: Thu Sep 26, 2019 9:17 pm
Location: Axvall, Sweden

Re: Got these errors.. dont have a clue.

Post by axbakk » Mon Oct 07, 2019 8:20 am

Maybe.. it was late. 😂 i Will try that dale. Thanks..

Yeah i could go to the problem of i knew were to start. Now i know how to read the errors.. Thanks mugi.

Let you know the progress. 👍🏻
Noobing around NESmaker just for fun! Totally noob in gamemaking and have no experience in programming! But I love retrogames! :D
User avatar
dale_coop
Posts: 4206
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: Got these errors.. dont have a clue.

Post by dale_coop » Mon Oct 07, 2019 9:19 am

Yeah...
About the interpretation of the error:
The command line 1st error says "HandleObjectCollisions.asm(202): CreateObject(26): Unknown label"

It means that the error i in the "HandleObjectCollisions.asm" script (in the "Routines\Basic\ModuleScripts\MainScripts\ScrollingPlatformer" folder), at line 202, starting from the 26th character of that line (ignore the first space characters of a line). The compilator says "Unknown label", he doesn't recognise this label/name/variable/constant/...

So, if you if you edit (open) that script and you go at line 202, you will find the :

Code: Select all

	CreateObject temp, temp1, #OBJ_MONSTER_DEATH, #$00, currentNametable ;; create "splat"
At the 26th caracter of that line is "#OBJ_MONSTER_DEATH".

On one of the screenshot, we can see that your "OBJ_MONSTER_DEATH has ";;;" in front of it. It means you might have click (accidentally?) on the button that disable/enable a constant.


The 2nd error is exactly the same problem (for the same constant).
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE / UNDERGROUND ADVENTURE (Arcade version - Byte-Off-2019)
User avatar
axbakk
Posts: 33
Joined: Thu Sep 26, 2019 9:17 pm
Location: Axvall, Sweden

Re: Got these errors.. dont have a clue.

Post by axbakk » Mon Oct 07, 2019 10:44 am

Nice. Gr8 explained. Now i know how to read the errors. 👌🏻
Yeah i saw that too the small ;;; before the obj_monster_death and thought it had something to do about it. Yeah i might have been there and clicked When the animation dident start in game When the enemy were killed.
Got to check that out..
Noobing around NESmaker just for fun! Totally noob in gamemaking and have no experience in programming! But I love retrogames! :D
User avatar
axbakk
Posts: 33
Joined: Thu Sep 26, 2019 9:17 pm
Location: Axvall, Sweden

Re: Got these errors.. dont have a clue.

Post by axbakk » Mon Oct 07, 2019 8:17 pm

it helped to press the button again. The game works.
But wonder why the enemy_death animation wont play. Player death animation worked by itself when i made one att action 8. but not the enemy death animation on action9..
where should i look.. the constant is set to 9
Noobing around NESmaker just for fun! Totally noob in gamemaking and have no experience in programming! But I love retrogames! :D
User avatar
dale_coop
Posts: 4206
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: Got these errors.. dont have a clue.

Post by dale_coop » Mon Oct 07, 2019 9:43 pm

For the monster animations... by default, the code is missing in some scripts....
Check those posts:
http://nesmakers.com/viewtopic.php?f=60&t=2532
http://nesmakers.com/viewtopic.php?f=35&t=1740 (in this one, by fixing the monster drops, I re-introduce the monster death animations)
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE / UNDERGROUND ADVENTURE (Arcade version - Byte-Off-2019)
User avatar
axbakk
Posts: 33
Joined: Thu Sep 26, 2019 9:17 pm
Location: Axvall, Sweden

Re: Got these errors.. dont have a clue.

Post by axbakk » Mon Oct 07, 2019 10:46 pm

ok thanks. will check them out tomorrow.
got som more issues to struggle.. but will look into some tutorials before asking for help.

But now its time for bed. :)
Noobing around NESmaker just for fun! Totally noob in gamemaking and have no experience in programming! But I love retrogames! :D
Post Reply