New Monster AI: Move towards player

User avatar
Redherring32
Posts: 34
Joined: Sat Aug 11, 2018 2:48 pm
Location: Usa

Re: New Monster AI: Move towards player

Post by Redherring32 » Tue Sep 11, 2018 1:30 am

I copied/pasted both scripts into ai script 10 but i got an error when compiling.
Can someone tell me what I did stupidly wrong?

Edit I thought I found out what my problem was,
and instead replaced null but I still got an error.
Looking like a fool since 2001...
User avatar
Redherring32
Posts: 34
Joined: Sat Aug 11, 2018 2:48 pm
Location: Usa

Re: New Monster AI: Move towards player

Post by Redherring32 » Tue Sep 11, 2018 2:13 am

OMG I undid what I did and still an error.
Attachments
Error.png
Error.png (115.4 KiB) Viewed 150 times
Looking like a fool since 2001...
User avatar
dale_coop
Posts: 1084
Joined: Fri Feb 16, 2018 7:05 am

Re: New Monster AI: Move towards player

Post by dale_coop » Tue Sep 11, 2018 10:08 am

In your HUD, you have used/made an Image variable?
It is not supported in this version of NESMaker. So you need to remove it.
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
User avatar
Redherring32
Posts: 34
Joined: Sat Aug 11, 2018 2:48 pm
Location: Usa

Re: New Monster AI: Move towards player

Post by Redherring32 » Fri Sep 14, 2018 3:28 am

I undid the changes I made to the HUD, but I get the same error...
Looking like a fool since 2001...
User avatar
dale_coop
Posts: 1084
Joined: Fri Feb 16, 2018 7:05 am

Re: New Monster AI: Move towards player

Post by dale_coop » Fri Sep 14, 2018 9:03 am

You did assigned the image var to an element of the HUD ?
If you did, select the element you previously assigned it to, select type "2-Text" and check you have nothing written in "String" property.
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
User avatar
Redherring32
Posts: 34
Joined: Sat Aug 11, 2018 2:48 pm
Location: Usa

Re: New Monster AI: Move towards player

Post by Redherring32 » Fri Sep 14, 2018 3:35 pm

I just edited the HUD tiles bmp, but I tried using the changes and I still get the error.
Looking like a fool since 2001...
User avatar
dale_coop
Posts: 1084
Joined: Fri Feb 16, 2018 7:05 am

Re: New Monster AI: Move towards player

Post by dale_coop » Fri Sep 14, 2018 9:51 pm

Still the same error?
It’s not the bmp the problem, it’s your HUD. In NESMaker, HUD & Boxes, in the “HUD elements” tab.
Did you used a “image variable” ? If you did, you need to remove it.
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
User avatar
Redherring32
Posts: 34
Joined: Sat Aug 11, 2018 2:48 pm
Location: Usa

Re: New Monster AI: Move towards player

Post by Redherring32 » Sat Sep 15, 2018 2:03 am

That did the trick!
Thanks a bunch!
Looking like a fool since 2001...
User avatar
dale_coop
Posts: 1084
Joined: Fri Feb 16, 2018 7:05 am

Re: New Monster AI: Move towards player

Post by dale_coop » Sat Sep 15, 2018 11:57 am

Glad you fixed it.
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
Post Reply